PDA

View Full Version : Moving servers... again



Fraser
2010-Nov-17, 05:04 PM
Hey everyone, I know everything seems to be working well, but I'm getting killed in server fees from Rackspace. So I'm going to be moving the forum to a new location - joining Universe Today in the Amazon EC2 cloud.

I'm going to try and minimize the disruption, but it's a 5 GB database file now, so it'll take a few hours to transfer over to the new location. I'll be shutting down the server here at some point for maintenance, and then importing the database into the new location. I'll try to move as quickly as I can, but I'm thinking it'll be down for at least 2-3 hours, and then it will take time for the domain name to propagate to the new location.

And then there will be a zillion little bugs to squash. :-)

Buttercup
2010-Nov-17, 07:07 PM
I'll survive the move. ;)

Swift
2010-Nov-17, 07:26 PM
I have this image of dozens of cardboard boxes full of threads, big burly guys putting them on a truck, and at the other end Fraser directing the guys with the boxes going "no, that one goes in Astronomy, and the big one goes in ATM". I just hope we can find the coffee pot before breakfast.

NEOWatcher
2010-Nov-17, 07:31 PM
I heard the move is going to be up to Don.

chrissy
2010-Nov-17, 08:41 PM
I have this image of dozens of cardboard boxes full of threads, big burly guys putting them on a truck, and at the other end Fraser directing the guys with the boxes going "no, that one goes in Astronomy, and the big one goes in ATM". I just hope we can find the coffee pot before breakfast.

You forgot one other BIG problem swift, the Box marked "vikings" needs to be redirected to Valhalla! :eek:

Swift
2010-Nov-17, 08:46 PM
You forgot one other BIG problem swift, the Box marked "vikings" needs to be redirected to Valhalla! :eek:
You mean you didn't want the box labeled "SPAM" in the Kitchen!?!

Moose
2010-Nov-17, 08:50 PM
Last one out, remember to turn off the breakers.

chrissy
2010-Nov-17, 08:54 PM
You mean you didn't want the box labeled "SPAM" in the Kitchen!?!

I have sold a load of boxes of spam already and more are reserved.....did I say that out loud? :shifty:

Swift
2010-Nov-17, 09:02 PM
Last one out, remember to turn off the breakers.
The Breakers (http://www.olivestudio.com/branch/wp-content/uploads/2010/06/The_Breakers_rear.jpg) ?

BetaDust
2010-Nov-17, 09:10 PM
Hey.. baut's still up! Great!

but it's a 5 GB database file now,

Where can I get the DVD version? :-)

AstroRockHunter
2010-Nov-17, 09:59 PM
Please, PLEASE, don't use 'Monback bros. hauling.

slang
2010-Nov-18, 07:06 AM
*TAP TAP TAP*

*cough* ... Is this thing on? .... Now, about those Amazonian ladies..

ETA: well, it looks like the IP did change, and people seem to be happily posting. Good.

Fraser
2010-Nov-18, 03:50 PM
It went without a hitch, except for transferring the monstrous database. It's so big it blocks out the Sun. It's like wrestling an octopus.

I'm going to be upgrading the software later today, so the admin work isn't done yet...

danscope
2010-Nov-18, 04:56 PM
I hope somebody loaded up that big crate of ferrets ? :)

AstroRockHunter
2010-Nov-18, 07:15 PM
I hope somebody loaded up that big crate of ferrets ? :)

Knew I was forgetting something.

NEOWatcher
2010-Nov-18, 07:20 PM
Please, PLEASE, don't use 'Monback bros. hauling.
How about MoonMan hauling?

Did that trash get moved with the trashcans in the move?

Hlafordlaes
2010-Nov-18, 08:59 PM
Thanks, Fraser. Had a mild panic attack when I attempted to log on to the forums when they were down. I'm over it now. Whew.

Moose
2010-Nov-18, 09:12 PM
Hey, did anybody find the box with the mod lounge's soft-serve ice cream dispenser? It should have been labeled "paperwork 6 gross".

chrissy
2010-Nov-18, 09:33 PM
Looks like the mod lounge got a new carpet and coffee machine...yay!

PetersCreek
2010-Nov-18, 09:37 PM
Has anyone seen my phenolic washer collection? It was in the box marked "truffles".

Swift
2010-Nov-18, 09:53 PM
Has anyone seen my phenolic washer collection? It was in the box marked "truffles".
Why, are your phenolics very dirty?

Its nice to see the moderators have done the best job of derailing this thread. :D

Sticks
2010-Nov-18, 10:13 PM
I got locked out for some reason. I had to get help reconfiguring my DNS set up

Tobin Dax
2010-Nov-18, 10:26 PM
It went without a hitch, except for transferring the monstrous database. It's so big it blocks out the Sun. It's like wrestling an octopus.

And there's the newest CT topic: Giant space octopus wrestles with Earth, causes pole shift.

astromark
2010-Nov-19, 05:22 AM
Ahhhh... so the news is out.. NASA finds giant octi and wrestles it to submission... and the forum has a new server... Good Job, Well Done.

Hlafordlaes
2010-Nov-19, 01:09 PM
Was trying to find a post of mine from a day or two ago, but no luck (only fairly old posts were returned, and nothing if filtered for last 7 days.) Wondering if there are issues indexing on the new system?

The Backroad Astronomer
2010-Nov-19, 04:17 PM
I hope somebody loaded up that big crate of ferrets ? :)

I'll take those. I am going on a flight and have an interesting idea for these.

Sticks
2010-Nov-19, 04:37 PM
This morning my laptop was still not finding the new site, and so like the desktop had to go to here (https://store.opendns.com/setup/device/windows-vista/) to reconfigure how the laptop looks at DNS instead of finding it automatically.

How long before automatic setting will pick it up?

NEOWatcher
2010-Nov-19, 05:54 PM
This morning my laptop was still not finding the new site, and so like the desktop had to go to here (https://store.opendns.com/setup/device/windows-vista/) to reconfigure how the laptop looks at DNS instead of finding it automatically.
Good, now anyone who can't see the board can use this post to see the board. http://www.cosgan.de/images/smilie/konfus/s045.gif

Solfe
2010-Nov-20, 12:03 AM
Last week, I accidentally selected the Server Install of Ubuntu. Since it was nothing like the glorious description of the DESKTOP version of Ubuntu, I was quite disappointed when I couldn't figure out the command prompt thingies and had to resort the live disc to save myself.

Having scratched the surface of server software and not liking it, I keep misreading the title of this as "Moving sewers... again". Does brief exposure to servers normally cause this extreme fear and dislike in people with middling computer skills like me?

slang
2010-Nov-20, 12:27 AM
Hlafordlaes, IIRC during the last migration there were indeed some lag effects wrt to indexing for searches. Yet OTOH I also remember some difficulties with searches, which could be solved by choosing the other tab (Search Single/Search Multiple).


Having scratched the surface of server software and not liking it [...]

You should never do this. It may render CD-ROMs and DVDs unreadable. The same may apply to magnetic media, but optical media are especially vulnerable to scratches.

AstroRockHunter
2010-Nov-20, 01:41 AM
... Does brief exposure to servers normally cause this extreme fear and dislike in people with middling computer skills like me?

In my experience, even brief exposures to servers causes extreme fear and dislike in people with exceptional computer skills, so don't feel so bad about it.

chrlzs
2010-Nov-20, 02:47 AM
Speaking of a zillion bugs and stuff lost in boxes... anyone seen the picture I *used* to have here?:
Animation showing how an Apollo Denier deceives (http://www.bautforum.com/showthread.php/108856-Need-help-debunking-a-couple-of-Moon-landing-hoax-claims?p=1809759#post1809759)

It *was* definitely there, linked from my album, but now if I look in my album, it has an empty box... Given the trouble I had understanding the crazy upload system you guys have here, I ain't doing it again unless I get a promise it won't get lost again... :)

slang
2010-Nov-20, 09:13 AM
anyone seen the picture I *used* to have here?

I had it for lunch, it was good!

But you're right, none of the images I uploaded show up in the attachment manager either. Since these are most likely not stored in the database itself, may not have been uploaded to the new server yet, or maybe it's an issue with a file directory not having the correct access level.

Grashtel
2010-Nov-20, 01:26 PM
This morning my laptop was still not finding the new site, and so like the desktop had to go to here (https://store.opendns.com/setup/device/windows-vista/) to reconfigure how the laptop looks at DNS instead of finding it automatically.

How long before automatic setting will pick it up?
As long as it takes for your ISP's DNS server to point to the new IP, which short of poking your ISP to update it (good luck with that) will take as long as it takes with nothing that you can do about it short of using an alternative DNS like you did.

Moose
2010-Nov-20, 01:32 PM
It can take 24-48 hours for a DNS update to propagate around the world (meaning cross-continent). If your DNS server is relatively close (in the internet sense) to the "authoritative server" (BAUT's registrar's DNS server), it can be as little as a couple of hours.

andyschlei
2010-Nov-21, 09:32 PM
It went without a hitch, except for transferring the monstrous database. It's so big it blocks out the Sun. It's like wrestling an octopus.

I'm going to be upgrading the software later today, so the admin work isn't done yet...

Fraser,

Not without a hitch. All of the old photos in the Astrophotography forum are missing. RickJ posted about this.

Can this be fixed?

Thanks,

--Andy

Fraser
2010-Nov-22, 12:43 AM
I think I fixed the photos problem. I needed to change the directory location where they're stored on the server to the new location.

Let me know if you find any other problems.

slang
2010-Nov-22, 01:03 AM
The pictures are now showing up again in my attachment manager, but they still don't show in threads like this one (http://www.bautforum.com/showthread.php/109567-SH2-282), at least, not to me (yet).

chrlzs
2010-Nov-22, 07:01 AM
I think I fixed the photos problem. I needed to change the directory location where they're stored on the server to the new location.

Sorry, but i don't you did.

Unlike Slang, my photo formerly here has not returned:
http://www.bautforum.com/album.php?albumid=208&attachmentid=13851
so obviously it doesn't show up where I have linked to it, either...

slang
2010-Nov-22, 07:43 AM
Unlike Slang, my photo formerly here has not returned:
http://www.bautforum.com/album.php?albumid=208&attachmentid=13851
so obviously it doesn't show up where I have linked to it, either...

Curiously, it does show up when I click that link. It might be something really simple, like maybe restarting the webserver or something silly like that.

Van Rijn
2010-Nov-22, 08:02 AM
I'm seeing it too. chrlzs are you seeing it yet?

HenrikOlsen
2010-Nov-22, 09:53 AM
Last week, I accidentally selected the Server Install of Ubuntu. Since it was nothing like the glorious description of the DESKTOP version of Ubuntu, I was quite disappointed when I couldn't figure out the command prompt thingies and had to resort the live disc to save myself.

Having scratched the surface of server software and not liking it, I keep misreading the title of this as "Moving sewers... again". Does brief exposure to servers normally cause this extreme fear and dislike in people with middling computer skills like me?
I think it's the result of having been indoctrinated by Microsoft and Appleused to clicky-clickygraphical interfaces as the way to do things.
The command line can be a scary and daunting place to be when you aren't used to it, especially if you have some idea of its power compared to the sanitized and protective clickies.
On the other hand, once you're used to it, only having a clicky interface feels really crippling because there are things that are a lot easier to do on the command line, with "simple" one line commands that does the job of hundreds of clicks and key presses.

Arneb
2010-Nov-22, 11:20 AM
On the other hand, once you're used to it, only having a clicky interface feels really crippling because there are things that are a lot easier to do on the command line, with "simple" one line commands that does the job of hundreds of clicks and key presses.

As they say in medicine - There is no substitute for competence, except...more competence.

andyschlei
2010-Nov-22, 05:45 PM
I think I fixed the photos problem. I needed to change the directory location where they're stored on the server to the new location.

Let me know if you find any other problems.

All the ones I checked seem to be OK. Thanks!

chrlzs
2010-Nov-22, 08:13 PM
That's weird. It does seem to be a propagation issue. I did manage to get that image to show in my album, but only by opening the jpg itself in a new window and refreshing *that* (refreshing the page did not work).

And I still cannot see the image in this post, where it is embedded, no matter what I try:
(Need help debunking..) (http://www.bautforum.com/showthread.php/108856-Need-help-debunking-a-couple-of-Moon-landing-hoax-claims?p=1809759#post1809759)

Guess I'll just give it a few more weeks.. Shipping is always slow to Australia... :)

Moose
2010-Nov-22, 09:08 PM
Your browser may be reading from the cache. You might make sure your browser is set to redownload any pages upon refresh.

chrlzs
2010-Nov-23, 11:23 AM
Your browser may be reading from the cache. You might make sure your browser is set to redownload any pages upon refresh.

Ahah - but it wasn't quite that simple. Yes, I knew that I had to 'hard refresh', and was doing so.. I thought..

BUT I've just done a little research - much as I like the Chrome browser, it obviously has a problem with often er... ignoring the 'ignore cache' request (Ctrl-Refresh) (- isn't that a lovely piece of tautology..). According to this:
http://code.google.com/p/chromium/issues/detail?id=603
this bug has been ignored by Google since 2008 - the only solution is to delete the cache, or try reloading it in an incognito window...

So - I apologise for suggesting it was you guys - my fault.. for believing in Chrome.. :)

tommac
2010-Nov-27, 01:16 AM
You can use my server if you want.

Sticks
2011-Apr-29, 05:59 AM
Thread closed pending moderator discussions

Swift
2011-Apr-29, 12:54 PM
Reopened - a spammer had posted and edited some links in. Go back to sleep little thread.

NEOWatcher
2011-Apr-29, 03:18 PM
Ah, thanks. I was beginning to think it was because of tommac's offer. :lol:

Jeff Root
2011-Apr-30, 12:49 AM
Someone commented on Tom's offer. I guess that must have been in a
different thread.

-- Jeff, in Minneapolis

Sticks
2011-Sep-26, 04:48 AM
We had another spammer on this thread, and not for the first time, which was originally an announcement by Fraser, and therefore a dead issue now.

With that in mind thread closed

Anyone wanting it reopened please get in contact with the moderation team