PDA

View Full Version : Posts by "TheAstronomer"



R.A.F.
2006-Jun-13, 10:34 AM
When I click on "todays posts" the first 12 are by TheAstronomer, and the dates are in the "future"...

What's up with that?...It's kinda annoying...

mickal555
2006-Jun-13, 11:00 AM
Thats weird... if I post on one it goes above!

R.A.F.
2006-Jun-13, 11:06 AM
Something else weird...all the posts show the same time, 5 AM.

edited to add...now they all say 10 PM.

What in the heck is going on???

NEOWatcher
2006-Jun-13, 11:53 AM
Something else weird...all the posts show the same time, 5 AM.

edited to add...now they all say 10 PM.

What in the heck is going on???
I assume it's the 365 days... forum

Post-dated posts... other discussion here (http://www.bautforum.com/showthread.php?t=42462), and Frasers' explanation is #6

Argos
2006-Jun-13, 01:19 PM
Im unable to mark the posts by TheAstronomer read.

NEOWatcher
2006-Jun-13, 01:47 PM
Im unable to mark the posts by TheAstronomer read.
Yep; that's one of the issues that I mentioned in the other thread. For me, it eventually worked. Probably only because the post date finally came about.
Today it's a little different, the forum indicates it is read, but the threads do not.

HenrikOlsen
2006-Jun-13, 02:24 PM
I mentioned it in another post (http://bautforum.com/showpost.php?p=757892&postcount=4) as well, it seems to be the result of removing the posts of a spammer.
The forum software had his post remembered as the last in the thread, but since it's gone, you can only read it up to the last post that is still there, which is older, the system remembers that the last post is younger, so still has it as unread.

The registered last post is only partially cleared by posting, then deleting the post. It'll reset who posted last to the last existing, but it still remembers the removed post as the last.

I think it's a result of an optimisation that isn't implemented 100% correctly, which isn't a wonder caches are notoriously difficult to code so they are updated correctly in every case.

NEOWatcher
2006-Jun-13, 04:14 PM
I mentioned it in another post (http://bautforum.com/showpost.php?p=757892&postcount=4) as well, it seems to be the result of removing the posts of a spammer.
...
I think there are 2 things going on.
In my situation its in the 365 days forum, there are articles that can not possibly be read, since they haven't technically been posted yet.

R.A.F.
2006-Jun-13, 04:24 PM
...all the posts show the same time, 5 AM...now they all say 10 PM.

Well, one "mystery" solved. The posts have the 5 AM time when I'm not logged in, and the 10 PM time when I am....DOH!!

Fraser
2006-Jun-13, 06:39 PM
Here's what's happening. I'm queuing up all the articles for What's Up, 1-2 weeks in advance in Wordpress. So they can go up like clockwork every day at 12:00am. We've got a bridge that automatically creates a thread in the forum that connects to the post. So if people want to comment on the blog, they're posted to BAUT. Very clever.

However, it doesn't quite work right yet. The Wordpress articles are properly future-dated and hidden until the right time, but the forum threads are all created instantly.

Needless to say, this isn't the functionality that I want, so I'm working on the fixes.

Since I've moved Universe Today over to Wordpress as well, and I want the same functionality, I'll need to iron out the bugs here first.

Does that make sense?

Tensor
2006-Jun-13, 07:26 PM
Here's what's happening.

snip.....

I'll need to iron out the bugs here first.

Does that make sense?

You have a problem and you're trying to fix it. OK, got it. ;)

HenrikOlsen
2006-Jun-13, 10:06 PM
As neowatcher said, there are two different things going on here, both times they've been discussed they've been confused so Fraser only responded to the easily explained thing in the 365 days forum with the predated articles.

I'd like to head comments on the other problem.

Fraser
2006-Jun-13, 10:19 PM
Well, I have no idea what's going on with the other problem, sadly.

Māori
2006-Jun-15, 11:10 AM
I think I knocked his old posts out by "posting a test". I hope that is okay?