View Full Version : annoying: IE 7 Favorites changing

2007-Jul-31, 03:30 AM
Are there any Windows/Microsoft "experts" out there that can help me solve an annoying problem:

Some of my "favorites" regularly get changed so they point to a .url file on my hard drive instead of the URL. One time, it will work fine, then the next time (even seconds later) when I click, nothing happens in the browser. When I check the favorite's properties, it now has a path on my system drive to a .url file instead of the URL.

It's driving me and my wife nuts! Has anyone else had this happen? The only speculation I have is that it's somehow at cross purposes with Firefox (which I use occasionally), but I've not been able to find any correlation.



2007-Aug-06, 05:11 AM
Just one bump - in case this filtered down before anyone answered... if it sinks again, I'll leave it be.


2007-Aug-06, 08:59 AM
Its Microsoft, what do you expect. Try this to make your browsing easier:


Alan G. Archer
2007-Aug-06, 11:11 AM
For what it's worth....

<< WARNING!!! Take careful notes of your settings before making any changes. >>

Navigate to My Computer >Tools >Folder Options... >File Types tab.

Click on the File Types tab and scroll down the registered file types box until you come to file extension 'URL,' the extension for 'Internet Shortcut.' Click on it to highlight. The "Details for 'URL' extension" should state that it opens with Internet Explorer. If not, click on the "Change..." button to change which program will open .URL files. It should be Internet Explorer. Make sure that the "Always use the selected program to open this kind of file" box is checked and then click the "OK" button.

Returning the the File Types window, click on the "Advanced" button and highlight action 'open.' Click the "Edit..." button. The "Application used to perform action" field for IE7 on my Windows XP Home Edition SP2 machine reads:

rundll32.exe ieframe.dll,OpenURL %l

On the same edit action window:

'Use DDE' is checked.

'Application' is: ieframe

'Topic' is: System

From what I've read, IE7 replaced IE6's use of shdocvw.dll. The "Application used to perform action" field for IE6 read:

rundll32.exe shdocvw.dll,OpenURL %l

Opera is my default browser. I also use Firefox and avoid using IE for casual surfing.

You could also use LSP-Fix (http://www.cexx.org/lspfix.htm), a Winsock 2 repair utility, to check the integrity of your Layered Service Provider. Please read their ispfix.txt Readme file before using.

2007-Aug-06, 12:05 PM
Thanks, Alan, I will try that when I get home.

Damburger - thanks for the product advice, but that wasn't what I asked... :)